|  RSS订阅  |  加入收藏

宝塔面板下phpMyadmin曝502错误,无法正常使用

宝塔面板是一款服务器管理软件,支持windows和linux系统,可以通过Web端轻松管理服务器,提升运维效率。phpMyAdmin是是一个以PHP为基础,以Web-Base方式架构在网站主机上的MySQL的数据库管理工具。今天在升级的过程中发现宝塔集成的phpMyAdmin数据库管理工具不能使用,打开曝502错误。
摘要
...

前几天修改博客界面,由于本地只有很少几篇测试文章,对内容溢出的测试不完全,虽然复制了一堆无用的内容在里面进行测试。今天就想到把服务器上的数据和本地同步一下。

自从有了宝塔面板,就不需要敲命令了,方便了不少。轻车熟路的打开面板,找到phpMyAdmin,点开,我X,竟然502 Bad Gateway错误。

第一个反应是面板中的phpMyAdmin服务器停止了,打开看了一下,正常。然后就去查看的phpMyAdmin的路径和nginx的配置是否一致,nginx中root  /www/server/phpmyadmin;和安装路径一致。监听端口也没错。然后就只能认为是phpMyAdmin文件损坏了,卸载重装。问题依旧。

这个我就不明白了。博客运行正常,说明服务器的基础环境都没问题。由于在面板中phpMyAdmin是通过端口访问的,那么有可能是端口问题了,先查看下面板中的安全选项,看下了phpMyAdmin对应的端口是放行的。联想到之前的邮件发送端口有可能被阿里云给封掉的原因,恶意揣测了下该不是我这个端口也被封了吧,进入阿里云控制台,发现在安全组中入站方面是放行的。为了那万分之一的可能,还是把相关的端口给删了重新再设置一遍。依然没有解决。

这个时候只能想象下是我操作了什么内容后造成的这种现象了。因为早上看到PHP7.2提升了底层安全性和提升性能。thinkPHP前几天也发布了5.0.13版本。所以上午带娃的空隙就把PHP升级到7.2,把框架从5.0.11升级到5.0.13了。从这之后好像phpMyAdmin就无法使用了,虽说是这之后,但是我真的不肯定,因为上一次使用phpMyAdmin还是刚部署博客的时候,中途一直没用过。只好死马当活马医了,尝试将PHP版本切回7.0,依然无效。可能也不是错在这里,又切回到7.2了。

最后去宝塔论坛查找,似乎也没有人遇到类似情况。吃过晚饭,没事继续一顿乱点,天,竟然在面板上软件管理上的phpMyAdmin栏找到设置按钮,点开,竟然还有PHP版本选择。果断点击PHP7.2。终于正常了。可以访问了,不过就是纳闷,既然是PHP版本的问题,为啥我之前切换到7.0的时候没有生效了,再次测试将PHP切换到7.0,这个设置也选择7.0,还是无效。不知道是否是面板本身的BUG。对我来所已经是无解了,不过好在7.2版本下能正常使用了。

2018-01-21更新

如果你没有做上述版本升级或者软件安装之类的工作,那你只需在软件管理——phpMyAdmin——设置——服务。选择重启。然后将设置中PHP版本,再次点击一下你当前对应的PHP版本。即可正常使用。

打赏
  phpMyAdmin    宝塔面板    
转载请注明出处,未经许可禁止商用!
西枫里 熊掌号
代码改变世界 ———— 半路出家,全程修道
发表评论
*依据《网络安全法》规定,您需实名认证后才能评论!
@萧瑟:以前还有这功能啊,可惜我没赶上。哈哈
@西枫里人:以前还可以查找代码中的漏洞,这些功能,基本上都去除了。感觉是越来越失望了吧
@萧瑟:可能是背负了盈利压力吧。自从上了5.8版本,好多小毛病
感觉宝塔现在做的没有之前的好了
@Waylee:也有可能是急速安装造成的,用编译安装可能好点吧,反正已经出了好几个错误了,以后还是能手动就手动吧。
我也遇到了,报错不能打开,然后一生宝塔黑